Topic: Nion Nx strange connection issue

Hi all,

I just managed to setup my nion nx. This is my first time using mediamatrix. I have configured the IP-settings and are able to see it in NWare and when I deploy a project, i get strange connection time-outs. A small window appears that says "Connection status NION #1 discovering.". The nion nx reports the correct project name but gives "message: EXCEPTION ASSIGNING ROLE: TIMEOUT DURING CONNECT. COMPLETED = NO."

Any ideas?


Re: Nion Nx strange connection issue

I suspect your problem is Pandad, which is discussed in this topic on our Knowledge Center.
There is troubleshooting section that will give you the right way to resolve the issue as well as give you the details of this powerful tool....
But, if you reboot your computer and the NION, it should now work.

Make it intuitive, never leave them guessing.


Re: Nion Nx strange connection issue

Note that this is a problem that happens every time I start the nion and NWare. Reboot does nothing.

The troubleshooting guide didn't help. More specifically:
*No MediaMatrix nodes are listed on the Remote Log tab of the Output Frame in NWare, but the devices respond when you use the PING command to contact them.

My node is visible in the remote log tab
*All the nodes on the Remote Log tab of the Output Frame in NWare show IP addresses instead of node names.

My nodes show with their names
*No nodes are listed on the Role Deployment dialog box.
My nodes show in the role deployment dialog box
*No projects are listed on the Upload and Connect dialog box.
No projects are listed in the upload and connect dialog box. This means that pandad is somehow crashed?
*No projects are listed on the dialog box when starting NWare Kiosk.
Havent tried kiosk yet

The only solution that is given in the troubleshooting is different flavours of restarting. Tried that, dozens of times. No difference.

I checked the list of nonos and I havent done any of those things.

Last edited by Coil (2021-05-30 17:22:10)


Re: Nion Nx strange connection issue

Try this.  Check in Task Manager that Pandad is not running.  If it is, End Process. (Pandad can be found in two locations, as a subset of NWare running as a "top" application, or it (normally) be found as a process (if running Win10, look for "More Details" in the bottom left corner to see processes).

1. Open Windows Explorer, and then navigate to the NWare installation folder.
2. Double-click pandad.exe or simply Pandad (application) to start Pandad in Interactive Mode.

The pandad> prompt is displayed. You can now enter commands. Type help to see a list of valid commands.

If Pandad is already running on your PC, the Interactive Mode Command Line Window will briefly open and close.

Now follow these instructions found on the KC; http://peaveyoxford.com/kc/index.htm#9823

If remote_link_status comes back as 1, try connecting/deploying/upload and connect again.

If it comes back as 0, send an email to mmtechsupport@peavey.com and we'll set up a Microsoft Teams call to help you figure out what is going wrong.

Good luck,

Make it intuitive, never leave them guessing.